POJ 3069 Saruman's Army(贪心)

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:

  直线上有N个点。点i的位置是ai.从这N个点中选取若干个,给它们加上标记。对于每一个点,其距离为R以内的区域必须有带标记的点。在满足这个条件的情况下,希望能尽量少的点添加标记。请问至少需要多少点被加上标记?

题解:

  这是一道很简单的贪心水题。从最左边开始考虑。对于这个点距离为R以内的最远的点添加标记,(尽量覆盖更靠右的点)。加上标记之后,用同样的方法找到其右侧R距离以内的最远的点添加标记。具体请看代码。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,r;
int a[1005];
void solve()
{
    sort(a,a+n);
    int i=0,ans=0;
    while(i<n)
    {
        int s=a[i++];//s是没有被覆盖的最左边的点的位置
        while(i<n&&a[i]<=s+r)//一直往右前进直到距s的距离大于r的点
            i++;
        int p=a[i-1];//p是新加上标记的点的位置
        while(i<n&&a[i]<=p+r)//一直往右前进直到距p的距离大于r的点
            i++;
        ans++;
    }
    cout<<ans<<endl;
}
int main()
{
    while(cin>>r>>n)
    {
        if(r==-1&&n==-1)
            break;
        for(int i=0;i<n;i++)
            cin>>a[i];
        solve();
    }
    return 0;
}
原文地址:https://www.cnblogs.com/orion7/p/7445665.html