状压DP Poj3311 Hie with the Pie

本人水平有限,题解不到为处,请多多谅解

本蒟蒻谢谢大家观看

题目:

Problem C: Poj3311 Hie with the Pie

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 58  Solved: 29
[Submit][Status][Web Board]

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.
给你一个有n+1(1<=n<=10)个点的有向完全图,用矩阵的形式给出任意两个不同点之间的距离。(其中从i到j的距离不一定等于从j到i的距离)现在要你求出从0号点出发,走过1到n号点至少一次,然后再回到0号点所花的最小距离

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0​

Sample Output

8

HINT

此题大致类似于上一题https://www.cnblogs.com/nlyzl/p/11307139.html

读入用从0~n,此题要求了必须从0号点出发,所以初始f[1][0]=0;即0号点选了以0号点结尾的值为0;

i需从1 ~(1<<n+1)-1;

j :  n~0 要逆循环,因为题目没有说不能不走回头路,所以我们要从n逆推,保证当前正着走与反着走的值都知道,以便于我们进行DP取min。

因为k与j我们都从0开始,所以左移时不需要 1<<(j-1)和1<<(k-1)

直接1<<j 和 1<<k即可;

转移:f[i][j]=min(f[i][j],min(f[i^1<<j][k],f[i][k])+dis[k][j]); //即应先从上一个状态与当前状态取min 后再来加上距离,再来转移(因为可以走回头路

最后统计时我们还要+dis[i][0];  //从任意一点到0的距离

code:

#include<bits/stdc++.h>
using namespace std;
int n;
int dis[21][21];
int ans;
int f[1<<20][21];
inline int read(){
     int x=0,f=1;
     char ch=getchar();
     while(ch<'0'||ch>'9'){
         if(ch=='-')
             f=-1;
         ch=getchar();
     }
     while(ch>='0'&&ch<='9'){
         x=(x<<1)+(x<<3)+(ch^48);
         ch=getchar();
     }
     return x*f;
}

inline void write(int x){
     char F[200];
     int tmp=x>0?x:-x ;
     if(x<0)putchar('-') ;
     int cnt=0 ;
        while(tmp>0)
        {
            F[cnt++]=tmp%10+'0';
            tmp/=10;
        }
        while(cnt>0)putchar(F[--cnt]) ;
}

int main()
{
    while(scanf("%d",&n)&&n!=0)
    {
        ans=INT_MAX;
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                dis[i][j]=read();
            }
        }
        memset(f,0x3f,sizeof(f));
        f[1][0]=0;
        for(int i=1;i<=(1<<n+1)-1;i++)
        {
            for(int j=n;j>=0;j--)
            {    
                
                if(i&1<<j)
                {
                    for(int k=0;k<=n;k++)
                    {
                        if(i&1<<k&&j!=k)
                        {
        f[i][j]=min(f[i][j],min(f[i^1<<j][k],f[i][k])+dis[k][j]);
                        }
                    }
                }
            }
        }
        for(int i=0;i<=n;i++)
            ans=min(ans,f[(1<<n+1)-1][i]+dis[i][0]);
        write(ans);
        cout<<endl;
    }
    return 0;    
} 
原文地址:https://www.cnblogs.com/nlyzl/p/11307300.html