zoj 2417 Lowest Bit(简单的模拟)

Lowest Bit

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26
88
0


Sample Output

2
8

分析:

(1)因为是100以内的数字所以只要找出能够组成100以内的所有二进制的数字然后一次减直到减后为0时就说明此时减掉的是最小有效位的那个数字。

#include <stdio.h>

int main()
{
    int n,bit_num[7],i;
    //得到可以组成100以内的二进制数的组合
    bit_num[0] = 1;
    for(i = 1;i<7;i++)
    bit_num[i] = bit_num[i-1]*2;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=6;i>=0;i--)
        {
            if(n>=bit_num[i])
            n -= bit_num[i];
            if(n==0)break;
        }
        printf("%d\n",bit_num[i]);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/newpanderking/p/2712264.html