poj 1007 DNA Sorting(排序快排)

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 67603   Accepted: 26858

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

 

#include <iostream>
#include <algorithm>
using namespace std;

typedef struct
{
    string dna;
    int count;
}DNA;
DNA dna[101];
int cmp(const void *a,const void *b)
{
    DNA *aa = (DNA *)a;
    DNA *bb = (DNA *)b;
    return aa->count-bb->count;
}
int main()
{
    int n,m;
    char c;
    cin>>n>>m;
    for(int i = 0; i < m; i++)
    {
        cin>>dna[i].dna;
        dna[i].count = 0;
        for(int j = 0; j < n; j++)
        for(int k = j+1; k < n; k++)
        {
            if(dna[i].dna[j]>dna[i].dna[k])
            dna[i].count++;
        }
    }
    qsort(dna,m,sizeof(dna[0]),cmp);
    for(int i = 0; i < m; i++)
    cout<<dna[i].dna<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/newpanderking/p/2704584.html