Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 453 Accepted Submission(s): 229
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;

int main()
{
    int num;
    double t,l,m;
    long long int N;
    cin>>num;
    while(num--)
    {
         cin>>N;
         t = N*log10(N);
         l = t - (long long int)t;
         m = pow(10,l);
        cout<<(int)m<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/newpanderking/p/2115438.html