【PAT甲级】1054 The Dominant Color

1054 The Dominant Color (20分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24


代码

柳神的:

查找数量过半的元素即可(过半元素一定唯一且占比最多)

#include <iostream>
#include <map>
using namespace std;
int main() {
    int m, n;
    scanf("%d %d", &m, &n);
    map<int, int> arr;
    int half = m * n / 2;
    for(int i = 0; i < n; i++) {
        for(int j = 0; j < m; j++) {
            int temp;
            scanf("%d", &temp);
            arr[temp]++;
            if(arr[temp] > half) {
                printf("%d", temp);
                return 0;
            }
        }
    }
    return 0;
}


【no】在map中存放数据,将出现的数字作为键,并将其存放进键值vector;同时查找键值vector长度最大的键,即是答案。

#include<iostream>
#include<map>
#include<vector>

using namespace std;

map<int,vector<int>> m;


//在map中存放数据,同时查找键值vector长度最大的键
int main() {
	int row,col;
	scanf("%d",&col);//列
	getchar();//不加也可以,scanf自动跳过空白符获取下一个整数
	scanf("%d",&row);//行

	int maxSizeKey(0),maxSize(0);
	for(int i=0; i<row; i++) {
		for(int j=0; j<col; j++) {
			int temp;
			scanf("%d",&temp);
			m[temp].push_back(temp);

			if(maxSize<m[temp].size()) {
				maxSize=m[temp].size();
				maxSizeKey=temp;
			}
		}
	}
	cout<<maxSizeKey<<endl;

	return 0;
}


知识点

  • scanf匹配数据时,能够自动跳过空白符(空格、回车、制表符)


单词

  • proportional:比例的
原文地址:https://www.cnblogs.com/musecho/p/12229430.html