1130 Infix Expression (25)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.


  Figure 1 Figure 2


Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))
题目大意:根据题中给出的二叉树写出表达式;
思路:先找出树的根节点,再dfs()遍历整棵树,得到表达式
dfs()关键在于找终止条件,对于有返回值的dfs还不是很熟练
#include<iostream>
#include<vector>
#include<string>
using namespace std;
vector<int> v[102];
vector<string> val(102);
int root;
string dfs(int index){
    if(index==-1) return "";
    if(v[index][1]!=-1){
    if(root!=index) return "(" + dfs(v[index][0]) + val[index] + dfs(v[index][1]) + ")";
    else return dfs(v[index][0]) + val[index] + dfs(v[index][1]);
    }
    return val[index];
}
int main(){
    int n, i, l, r;
    cin>>n;
    vector<int> exist(n+1, 0);
    string id;
    for(i=1; i<=n; i++){
        cin>>id>>l>>r;
        v[i].push_back(l);
        v[i].push_back(r);
        val[i] = id;
        if(l!=-1)exist[l]=1;
        if(r!=-1)exist[r]=1;
    }
    for(i=1; i<=n; i++){ if(exist[i]==0){ root=i; break; }}
    cout<<dfs(root)<<endl;
return 0;}
有疑惑或者更好的解决方法的朋友,可以联系我,大家一起探讨。qq:1546431565
原文地址:https://www.cnblogs.com/mr-stn/p/9177599.html