1115 Counting Nodes in a BST (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6


题目大意:给出一串数,建立二叉树。找出最底层和次底层节点个数
思路:dfs()遍历树,每遍历依次某一深度的节点树加一;遍历到节点为空指针为止。还需要维护一个maxdepth变量,记录树的最深深度
#include<iostream>
#include<vector>
using namespace std;
vector<int> ans(1001, 0);
int maxdepth=-1;
class node{
public:
  int val;
  node *left, *right;
  node(){left=right=NULL;}
};

node* insert(node* root, int val){
  if(root==NULL){
    node* newnode = new node();
    newnode->val = val;
    return newnode;
  }
  if(val<=root->val) root->left=insert(root->left, val);
  else root->right=insert(root->right, val);
  return root;
}

void dfs(node* root, int depth){
  ans[depth]++;
  if(maxdepth<depth) maxdepth = depth;
  if(root->left!=NULL)dfs(root->left, depth+1);
  if(root->right!=NULL)dfs(root->right, depth+1);
}

int main(){
  int n, i, t;
  node* root=NULL;
  cin>>n;
  for(i=0; i<n; i++){
    cin>>t;
    root=insert(root, t);
  }
  dfs(root, 0);
  printf("%d + %d = %d", ans[maxdepth], ans[maxdepth-1], ans[maxdepth-1]+ans[maxdepth]);
  return 0;
}
有疑惑或者更好的解决方法的朋友,可以联系我,大家一起探讨。qq:1546431565
原文地址:https://www.cnblogs.com/mr-stn/p/9157889.html