1120 Friend Numbers (20 分)(set)

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10^4.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

分析:

在接收输入数据的时候就把该数字的每一位相加,并把结果插入一个set集合中。因为set是有序的、不重复的,所以set的size值就是输出的个数,set中的每一个数字即所有答案的数字序列

此为C/C++版,Java版本请戳:http://www.liuchuo.net/archives/2736

原文链接:https://blog.csdn.net/liuchuo/article/details/53990412

题解

set:内部自动排序+不含重复元素!

#include <bits/stdc++.h>

using namespace std;

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,tmp;
    set<int> st;
    cin>>n;
    for(int i=0;i<n;i++){
        int sum=0;
        cin>>tmp;
        while(tmp){
            sum+=tmp%10;
            tmp/=10;
        }
        st.insert(sum);
    }
    cout<<st.size()<<endl;
    for(auto it=st.begin();it!=st.end();it++){
        if(it!=st.begin())
            cout<<" "<<*it;
        else cout<<*it;
    }
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15776847.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15776847.html