1064 Complete Binary Search Tree (30 分)(二叉查找树BST)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.
    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题解

这道题由于过于简单,柳神竟然没po在csdn上(不是
image

#include <bits/stdc++.h>

using namespace std;
const int maxn=1010;
int CBT[maxn],t=0,n,num[maxn];
void inOrder(int root)
{
    if(root>n) return;
    inOrder(2*root);
    CBT[root]=num[t++];//根节点处赋值num[t]
    inOrder(2*root+1);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>num[i];
    }
    sort(num,num+n);
    inOrder(1);
    for(int i=1;i<=n;i++)
    {
        cout<<CBT[i];
        if(i!=n) cout<<" ";
    }
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15767295.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15767295.html