1108 Finding Average (20 分)(字符串处理)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A “legal” input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line “ERROR: X is not a legal number” where X is the input. Then finally print in a line the result: “The average of K numbers is Y” where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output “Undefined” instead of Y. In case K is only 1, output “The average of 1 number is Y” instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

分析:

用非常好用的sscanf和sprintf即可解决~
sscanf() – 从一个字符串中读进与指定格式相符的数据
sprintf() – 字符串格式化命令,主要功能是把格式化的数据写入某个字符串中

原文链接:https://blog.csdn.net/liuchuo/article/details/51985816

题解

这题也做过了,当时还因不够细心在多个数字输出的时候少了复数s。

#include <bits/stdc++.h>

using namespace std;

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,cnt=0;
    char a[50],b[50];
    double temp=0,sum=0;
    cin>>n;
    for(int i=0;i<n;i++){
        scanf("%s",a);
        sscanf(a,"%lf",&temp);
        //cout<<temp<<endl;
        sprintf(b,"%.2f",temp);
        //printf("%s\n",b);
        int flag=0;
        for(int j=0;j<strlen(a);j++){
            if(a[j]!=b[j]) flag=1;
        }
        if(flag||temp<-1000||temp>1000){
            printf("ERROR: %s is not a legal number\n",a);
            continue;
        }else{
            sum+=temp;
            cnt++;
        }
    }
    if(cnt==1) printf("The average of 1 number is %.2f", sum);
    else if (cnt>1) printf("The average of %d numbers is %.2f", cnt, sum/cnt);
    else printf("The average of 0 numbers is Undefined");
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15760557.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15760557.html