1033 To Fill or Not to Fill (25 分)(贪心)【回顾】

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

分析:贪心算法。

0.假设增加一个目的地处的加油站,距离为目的地的距离,价格为0,考虑从0距离开始能否到达最后一个加油站的问题
1.因为先开始没有油,所以如果所有的加油站距离都没有等于0的,那么说明车哪也去不了,直接输出并return
2.将加油站按照距离dis从小到大排序
3.先去第一个加油站,设置变量nowdis表示当前所在的距离,maxdis是能够到达的最大距离,nowprice是当前的站点的价格,totalPrice是总的价格。

贪心思想:

0.寻找比自己距离远的,到能够到达的最大距离之间的加油站,看他们的油价。如果找到了更低价格的油价,就加油到刚好能到达那个加油站的距离的油,然后去那个更低价格的加油站(有更低的我一分都不想多花在别的距离上,只加到刚好满足更低价格的加油站的距离就行,那样以后的路程我就可以以更低的价格行驶啦)

1.如果找不到更低的,就找尽可能低的油价的加油站,在当前加油站加满油之后过去。因为想要让路程上使用的尽可能是低价的油,既然没有比当前更低价格的了,就让油箱加到最大值,这样能保证利益最大化,保证最大的距离使用的是便宜的油。

原文链接:https://blog.csdn.net/liuchuo/article/details/52497109

算法笔记分析

image

思路

image
image
image

题解

#include <bits/stdc++.h>

using namespace std;
const int maxn=510;
const int INF=1000000000;
struct station{
    double price,dis;
}st[maxn];
bool cmp(station a,station b)
{
    return a.dis<b.dis;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n;
    double Cmax,D,Davg;
    scanf("%lf%lf%lf%d",&Cmax,&D,&Davg,&n);
    for(int i=0;i<n;i++){
        scanf("%lf%lf",&st[i].price,&st[i].dis);
    }
    st[n].price=0;
    st[n].dis=D;
    sort(st,st+n,cmp);
    if(st[0].dis!=0){
        printf("The maximum travel distance = 0.00\n");
        return 0;
    }
    int now=0;
    double ans=0,nowTank=0,Max=Cmax*Davg;
    while(now<n){
        int k=-1;
        double priceMin=INF;
        for(int i=now+1;i<=n&&st[i].dis-st[now].dis<=Max;i++){
            if(st[i].price<priceMin){
                priceMin=st[i].price;
                k=i;
                if(priceMin<st[now].price) break;
            }
        }
        if(k==-1) break;
        double need=( st[k].dis-st[now].dis )/Davg;
        if(priceMin<st[now].price){
            if(nowTank<need){
                ans+=(need-nowTank)*st[now].price;
                nowTank=0;
            }else
                nowTank-=need;
        }else{
            ans+=( Cmax - nowTank )*st[now].price;
            nowTank=Cmax-need;
        }
        now=k;
    }
    if(now==n){
        printf("%.2f\n",ans);
    }else{
        printf("The maximum travel distance = %.2f\n",st[now].dis+Max);
    }
    return 0;
}

详解版题解

image
image
image

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15617088.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15617088.html