1062 Talent and Virtue (25 分)(排序)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=105), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades — that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification — that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

生词

英文 解释
Talent and Virtue 才德
philosopher 哲学家
outweigh 超过
qualified 有资格的
tie 平局

题目大意:

输入第1行给出3个正整数,分别为:N为考生总数;L为录取最低分数线,即德分和才分均不低于L的考生才有资格被考虑录取;H为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线L的考生也按总分排序,但排在第三类考生之后。输出第1行首先给出达到最低分数线的考生人数M,随后M行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出~

分析:

用结构体存储。写好cmp函数~结构体数组vector v[4]中v[0]保存第一类考生,v[1]保存第二类考生…以此类推~写好cmp函数很重要,cmp函数中,排序先按照总分排序,然后按照德分排序,最后按照准考证号排序…最后输出符合条件的结果~

原文链接:https://blog.csdn.net/liuchuo/article/details/52122102

题解

相比做乙级的时候已经精简很多了,但还是比不了柳神的精简。。

#include <bits/stdc++.h>

using namespace std;
struct person
{
    string s;
    int v,t;
};
bool cmp(person a,person b)
{
    int s1=a.v+a.t,s2=b.v+b.t;
    if(s1!=s2) return s1>s2;
    else{
        if(a.v!=b.v) return a.v>b.v;
        else return a.s<b.s;
    }
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,l,h,a,b;
    string s;
    cin>>n>>l>>h;
    vector<person> v;
    vector<person> tmp[4];
    for(int i=0;i<n;i++){
        cin>>s>>a>>b;
        if(a>=l&&b>=l){
            v.push_back({s,a,b});
        }
    }
    for(int i=0;i<v.size();i++){
        if(v[i].v>=h&&v[i].t>=h){
            tmp[0].push_back(v[i]);
        }else if(v[i].v>=h&&v[i].t<h){
            tmp[1].push_back(v[i]);
        }else if(v[i].v<h&&v[i].t<h&&v[i].v>=v[i].t){
            tmp[2].push_back(v[i]);
        }else{
            tmp[3].push_back(v[i]);
        }
    }
    cout<<v.size()<<endl;
    for(int i=0;i<4;i++){
        sort(tmp[i].begin(),tmp[i].end(),cmp);
        for(int j=0;j<tmp[i].size();j++){
            cout<<tmp[i][j].s<<" "<<tmp[i][j].v<<" "<<tmp[i][j].t<<endl;
        }
    }
    return 0;
}

柳神代码

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
struct node {
    int num, de, cai;
};
int cmp(struct node a, struct node b) {
    if ((a.de + a.cai) != (b.de + b.cai))
        return (a.de + a.cai) > (b.de + b.cai);
    else if (a.de != b.de)
        return a.de > b.de;
    else
        return a.num < b.num;
}
int main() {
    int n, low, high;
    scanf("%d %d %d", &n, &low, &high);
    vector<node> v[4];
    node temp;
    int total = n;
    for (int i = 0; i < n; i++) {
        scanf("%d %d %d", &temp.num, &temp.de, &temp.cai);
        if (temp.de < low || temp.cai < low)
            total--;
        else if (temp.de >= high && temp.cai >= high)
            v[0].push_back(temp);
        else if (temp.de >= high && temp.cai < high)
            v[1].push_back(temp);
        else if (temp.de < high && temp.cai < high && temp.de >= temp.cai)
            v[2].push_back(temp);
        else
            v[3].push_back(temp);
    }
    printf("%d\n", total);
    for (int i = 0; i < 4; i++) {
        sort(v[i].begin(), v[i].end(), cmp);
        for (int j = 0; j < v[i].size(); j++)
            printf("%d %d %d\n", v[i][j].num, v[i][j].de, v[i][j].cai);
    }
    return 0;
}

本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15606978.html

原文地址:https://www.cnblogs.com/moonlight1999/p/15606978.html