1070 Mooncake (25 分)(贪心算法)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the regions culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

生词

英文 解释
bakery 烘烤产品
fillings and crusts 馅料和面皮
inventory 清单,库存
partial 部分的

题目大意:

N表示月饼种类,D表示月饼的市场最大需求量,给出每种月饼的数量和总价,问根据市场最大需求量,这些月饼的最大销售利润为多少~

分析:

首先根据月饼的总价和数量计算出每一种月饼的单价,然后将月饼数组按照单价从大到小排序,根据需求量need的大小,从单价最大的月饼开始售卖,将销售掉这种月饼的价格累加到result中,最后输出result即可~

原文链接:https://blog.csdn.net/liuchuo/article/details/51985849

23分答案

样例2没过,,,

#include <bits/stdc++.h>

using namespace std;

struct node
{
    double amount,total,unit;
};
bool cmp(node a,node b)
{
    return a.unit>b.unit;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n;
    double d;
    cin>>n>>d;
    vector<node> v(n);
    for(int i=0;i<n;i++){
        cin>>v[i].amount;
    }
    for(int i=0;i<n;i++){
        cin>>v[i].total;
        v[i].unit=v[i].total/v[i].amount;
    }
    sort(v.begin(),v.end(),cmp);
    double cnt=0,sum=0;
    for(int i=0;i<n;i++){
        if(cnt<=d){
            cnt+=v[i].amount;
            sum+=v[i].total;
        }else {
            sum-=v[i-1].unit*(cnt-d);
            break;
        }
    }
    printf("%.2f\n",sum);
    return 0;
}

柳神答案

#include <bits/stdc++.h>

using namespace std;

struct node
{
    double amount,total,unit;
};
bool cmp(node a,node b)
{
    return a.unit>b.unit;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n;
    double d;
    cin>>n>>d;
    vector<node> v(n);
    for(int i=0;i<n;i++){
        cin>>v[i].amount;
    }
    for(int i=0;i<n;i++){
        cin>>v[i].total;
        v[i].unit=v[i].total/v[i].amount;
    }
    sort(v.begin(),v.end(),cmp);
    double sum=0;
    for(int i=0;i<n;i++){
        if(v[i].amount<=d){
            sum+=v[i].total;
        }else {
            sum+=v[i].unit*d;
            break;
        }
        d-=v[i].amount;
    }
    printf("%.2f\n",sum);
    return 0;
}
原文地址:https://www.cnblogs.com/moonlight1999/p/15599206.html