1057 Stack (30 分)(树状数组)【暂时pass】

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意:

现请你实现一种特殊的堆栈,它多了一种操作叫“查中值”,即返回堆栈中所有元素的中值。对于N个元素,若N是偶数,则中值定义为第N/2个最小元;若N是奇数,则中值定义为第(N+1)/2个最小元~

分析:

用排序查询的方法会超时~用树状数组,即求第k = (s.size() + 1) / 2大的数。查询小于等于x的数的个数是否等于k的时候用二分法更快~

原文链接:https://blog.csdn.net/liuchuo/article/details/52231409

柳神代码

#include <cstdio>
#include <stack>
#define lowbit(i) ((i) & (-i))
const int maxn = 100010;
using namespace std;
int c[maxn];
stack<int> s;
void update(int x, int v) {
    for(int i = x; i < maxn; i += lowbit(i))
        c[i] += v;
}
int getsum(int x) {
    int sum = 0;
    for(int i = x; i >= 1; i -= lowbit(i))
        sum += c[i];
    return sum;
}
void PeekMedian() {
    int left = 1, right = maxn, mid, k = (s.size() + 1) / 2;
    while(left < right) {
        mid = (left + right) / 2;
        if(getsum(mid) >= k)
            right = mid;
        else
            left = mid + 1;
    }
    printf("%d\n", left);
}
int main() {
    int n, temp;
    scanf("%d", &n);
    char str[15];
    for(int i = 0; i < n; i++) {
        scanf("%s", str);
        if(str[1] == 'u') {
            scanf("%d", &temp);
            s.push(temp);
            update(temp, 1);
        } else if(str[1] == 'o') {
            if(!s.empty()) {
                update(s.top(), -1);
                printf("%d\n", s.top());
                s.pop();
            } else {
                printf("Invalid\n");
            }
        } else {
            if(!s.empty())
                PeekMedian();
            else
                printf("Invalid\n");
        }
    }
    return 0;
}

疑点

不知道为啥用这个vector<int> v无法把stack里的值转移过去QAQ

int PeekMedian(stack<string> a){
    vector<int> v;
    int n=a.size();
    while(n){
        v.push_back(atoi(a.top().c_str()));
        a.pop();
    }
    for(int i=0;i<n;i++)
        cout<<v[i]<<endl;
    sort(v.begin(),v.end());
    return v[n/2];
}

超时17分代码

#include <bits/stdc++.h>

using namespace std;

int PeekMedian(stack<string> a){
    vector<int> v;
    int n=a.size();
    int number[n];
    for(int i=0;i<n;i++){
        int num=atoi(a.top().c_str());
        number[i]=num;
        a.pop();
    }
    sort(number,number+n);
    return number[(n-1)/2];
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n;
    cin>>n;
    getchar();
    stack<string> a;
    vector<string> v(n);
    for(int i=0;i<n;i++){
        getline(cin,v[i]);
        if(v[i][1]=='u'){
            a.push(v[i].substr(5));
        }else if(v[i][1]=='o'){
            if(a.size()!=0){
                cout<<a.top()<<endl;
                a.pop();
            }else{
                cout<<"Invalid"<<endl;
                continue;
            }
        }else if(v[i][1]=='e'){
            if(a.size()!=0){
                cout<<PeekMedian(a)<<endl;
            }else{
                cout<<"Invalid"<<endl;
                continue;
            }
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/moonlight1999/p/15598811.html