1058 A+B in Hogwarts (20 分)(进制转换)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system — as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

题目大意:

17个Sickle对换一个Galleon,29个Knut对换一个Sickle。根据Galleon.Sickle.Knut的方式相加A和B

分析:

像相加算术一样从后往前按位相加,处理好进位~

原文链接:https://blog.csdn.net/liuchuo/article/details/52121255

题解

#include <bits/stdc++.h>

using namespace std;

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int a,b,c,x,y,z;
    scanf("%d.%d.%d",&a,&b,&c);
    scanf("%d.%d.%d",&x,&y,&z);
    int tmp=0;
    c=c+z;
    if(c>=29){
        c-=29;
        tmp=1;
    }
    b=b+y+tmp;
    tmp=0;
    if(b>=17){
        b-=17;
        tmp=1;
    }
    a=a+x+tmp;
    printf("%d.%d.%d",a,b,c);
    return 0;
}
原文地址:https://www.cnblogs.com/moonlight1999/p/15590533.html