1050 String Subtraction (20 分)(hash)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意:

给出两个字符串,在第一个字符串中删除第二个字符串中出现过的所有字符并输出

分析:

用flag[256]数组变量标记str2出现过的字符为true,输出str1的时候根据flag[str1[i]]是否为true,如果是true就不输出

注意:

使用int lens1 = strlen(s1);int lens2 = strlen(s2);的形式,否则直接放在for循环里面会超时~
如果使用gets前面请使用char str[100000]而非char *str~~

原文链接:https://blog.csdn.net/liuchuo/article/details/52146689

题解

#include <bits/stdc++.h>

using namespace std;
int Hash[10000];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    string s1,s2;
    getline(cin,s1);
    getline(cin,s2);
    for(int i=0;i<s2.size();i++){
       Hash[s2[i]]=1;
    }
    for(int i=0;i<s1.size();i++){
       if(Hash[s1[i]]!=1)
        cout<<s1[i];
    }
    return 0;
}
原文地址:https://www.cnblogs.com/moonlight1999/p/15584845.html