1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five
/* water..
 */
#include "iostream"
#include "cstring"
#include "stack"
using namespace std;
char num[10][6] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
int  main() {
    stack<int>s;
    char str[101];
    int sum = 0;
    cin >> str;
    for (int i = 0; i < strlen(str);i++) {
        sum += str[i] - '0';
    }
    if (sum == 0) {
        cout << "zero" << endl;
        return 0;
    }
    while (sum != 0) {
        s.push(sum % 10);
        sum /= 10;
    }
    int k = 1;
    while (!s.empty()) {
        if(k == 1)
        cout<<num[s.top()];
        else
        cout << " "<<num[s.top()];
        s.pop();
        k++;
    }
    cout << endl;
    return 0;
}
原文地址:https://www.cnblogs.com/minesweeper/p/6275134.html