Back to High School Physics

欢迎访问我的新博客:http://www.milkcu.com/blog/

原文地址:http://www.milkcu.com/blog/archives/uva10071.html

题目描述

Problem B

Back to High School Physics

Input: standard input

Output: standard output

A particle has initial velocity and constant acceleration. If its velocity after certain time is v then what will its displacement be in twice of that time?

Input

The input will contain two integers in each line. Each line makes one set of input. These two integers denote the value of v (-100 <= v <= 100) and t(0<=t<= 200) ( t means at the time the particle gains that velocity) 

Output

For each line of input print a single integer in one line denoting the displacement in double of that time.

Sample Input

0 0
5 12

Sample Output

0
120
___________________________________________________________________________________
Shahriar Manzoor

解题思路

一个质点有一定的初速度和恒定的加速度。如果质点一段时间后的速度为v,那么两段时间后质点的位移是多少。
输入为一段时间后的速度v和质点获得这个速度所用的时间。

代码实现

#include <iostream>
using namespace std;
int main(void) {
	int v, t;
	while(cin >> v >> t) {
		cout << v * 2 * t << endl;
	}
	return 0;
}

(全文完)

原文地址:https://www.cnblogs.com/milkcu/p/3808856.html