HDU 3232 && UVA 12230 (简单期望)


Crossing Rivers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 738    Accepted Submission(s): 387

Problem Description
You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.
Fortunately, there is one "automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You're so slim that carrying you does not change the speed of any boat.
Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the expected time to reach B from A? Your walking speed is always 1.
To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is uniformly chosen from interval [0, L], and the boat is equally like to be moving left or right, if it’s not precisely at the river bank.
 
Input
There will be at most 10 test cases. Each case begins with two integers n and D, where n (0 <= n <= 10) is the number of rivers between A and B, D (1 <= D <= 1000) is the distance from A to B. Each of the following n lines describes a river with 3 integers: p, L and v (0 <= p < D, 0 < L <= D, 1 <= v <= 100). p is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last test case is followed by n=D=0, which should not be processed.
 
Output
For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.
Print a blank line after the output of each test case.
 
Sample Input
1 1 0 1 2 0 1 0 0
 
Sample Output
Case 1: 1.000 Case 2: 1.000
 
Source
2009 Asia Wuhan Regional Contest Hosted by Wuhan University

题目链接:http://acm.hdu.edu.cn/showproblem.php?

pid=3232

题目大意:A,B相距D,A,B间有n条河,河宽Li,每条河上有一个速度为vi的船。在河山来回行驶,每条河离A的距离为pi,如今求从A到B时间的期望。步行速度始终为1

题目分析:首先如果所有步行则期望为D,如今每遇到一条河,求过河时间的期望,等待时间的区间为(0,2*L/v)。船在每一个地方都是等可能的。所以等待的期望就是(0 + 2*L/v) / 2 = L / v,又过河还要L / v,所以总的渡河期望值为2 * L / v。所以每遇到一条河拿D减去如果步行过河的期望L再加上实际过河期望2 * L / v就可以,最后发现和p没有卵关系,真开心~

#include <cstdio>

int main()
{
    int n;
    double D;
    int ca = 1;
    while(scanf("%d %lf", &n, &D) != EOF && (n + D))
    {
        double p, l, v;
        for(int i = 0; i < n; i++)
        {
            scanf("%lf %lf %lf", &p, &l, &v);
            D = D - l + l * 2.0 / v;
        }
        printf("Case %d: %.3f

", ca ++ , D);
    }
}


 

原文地址:https://www.cnblogs.com/mfmdaoyou/p/6994328.html