ZOJ Problem Set–1382 A Simple Task

Time Limit: 2 Seconds      Memory Limit: 65536 KB


Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example
For n = 24, o = 3 and p = 3.

Task
Write a program which for each data set:

reads a positive integer n,
computes the odd integer o and the nonnegative integer p such that n = o2^p,
writes the result.

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.


Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

Sample Input

1
24


Sample Output

3 3


Source: Central Europe 2001, Practice

算是一道简单题吧,用表驱动法,先将使用到的2^n打一张表,然后根据表中的数据进行计算就可以了。重点在看清题意,注意O和P的取值范围。代码如下:

#include<iostream>
using namespace std;
const int MAX = 21;
void intialBaseData(int **arr)
{
  **arr = 1;
  int pow = 1;
  for(int i = 1; i < MAX; i++)
  {
    pow *= 2;
    *(*arr + i) = pow;
  }
}
int main()
{
  int *baseArr = new int[MAX];
  intialBaseData(&baseArr);
  int num, digit;cin>>num;
  while(num-- && cin>>digit)
  {
    for(int i = 0; i < MAX; i++)
    {
      if(digit%baseArr[i] == 0 && (digit/baseArr[i])%2 != 0)
      {
        cout<<digit/baseArr[i]<<""<<i;
        break;
      }
    }
    cout<<endl;
  }
  delete []baseArr;
  return 0;
}
原文地址:https://www.cnblogs.com/malloc/p/2393326.html