Generate Passwords


Time Limit: 1 Second      Memory Limit: 32768 KB


To prepare for programming contests or coding examinations, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input

There are multiple test cases. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

For each case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "No account is modified."

Sample Input:

2
Team000001 R1spOdfa
Team000002 Rlsp0dfa
1
team110 abcdefg332
0
Sample Output:
2
Team000001 R@spodfa
Team000002 RLsp%dfa
No account is modified.

Author: CHEN, Yue
Source: CYJJ's Funny Contest #1, Killing in Seconds
#include<iostream>
#include<sstream>
#include<string>
#include<vector>
using namespace std;
int main(void)
{
  int cases;
  while(cin>>cases && cases != 0)
  {
    string u,p,result = "";
    vector<string> v;
    for(int i = 1; i <= cases; i++)
    {
      result = "";
      cin>>u>>p;
      istringstream is(p);
      int re = 0;
      for(char c;is >> c;)
      {
        switch(c)
        {
        case '1':
          result += "@";
          re++;
          break;
        case '0':
          result += "%";
          re++;
          break;
        case 'l':
          result += "L";
          re++;
          break;
        case 'O':
          result += "o";
          re++;
          break;
        default:
          result += c;
        }
      }
      if(re != 0)
      {
        v.push_back(u + " " + result);
      }
    }
    if(v.size() == 0)
    {
      cout<<"No account is modified."<<endl;
    }
    else
    {
      cout<<v.size() <<endl;
      for(int j = 0; j < v.size(); j++)
      {
        cout<<v[j]<<endl;
      }
    }
  }
  return 0;
}
原文地址:https://www.cnblogs.com/malloc/p/2193589.html