POJ 2182 Lost Cows

Lost Cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8101   Accepted: 5163

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1
题目大意:有n头牛,它们的编号是乱序的,给出每头牛前面有几头牛的序号比它的小,求牛的编号序列。
#include <stdio.h>

int result[10001];
int arr[10001];
int a[10001];
int n;
 
int lowbit(int num)
{
    return num & -num;
}

void plus(int pos, int num)
{
    while(pos <= n)
    {
        arr[pos] += num;
        pos += lowbit(pos);
    }
}

int getsum(int pos)
{
    int sum = 0;
    while(pos > 0)
    {
        sum += arr[pos];
        pos -= lowbit(pos);
    }
    return sum;
}

int BSearch(int num)
{
    int low = 1;
    int high = n;
    int mid;
    while(low <= high)
    {
        mid = (low + high)>>1;
        int temp = getsum(mid);
        if (temp >= num)
        {
            high = mid - 1;
        }
        else
        {
            low = mid + 1;
        }
    }
    return low;
}

int main()
{
    scanf("%d", &n);
    for (int i = 1; i <= n; i++)
    {
        plus(i, 1);
    }
    for (int i = 2; i <= n; i++)
    {
        scanf("%d", &a[i]);
    }
    for (int i = n; i >= 1; i--)
    {
        result[i] = BSearch(a[i] + 1);
        plus(result[i], -1);
    }
    for (int i = 1; i <= n; i++)
    {
        printf("%d\n", result[i]);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lzmfywz/p/3110386.html