HDU What Are You Talking About

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 9522    Accepted Submission(s): 2971


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 
Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 
Output
In this problem, you have to output the translation of the history book.
 
Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 
Sample Output
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
#include <stdio.h>
#include <string>
#include <iostream>
#include <cstring>
using namespace std;

#define  MAXWORDS 26

typedef struct node
{
    char str[11];
    node *next[MAXWORDS];
}TreeNode;

TreeNode *pRoot1 = NULL;

void ZeroNode(TreeNode *&pRoot)
{
    for (int i = 0; i < MAXWORDS; i++)
    {
        pRoot->next[i] = NULL;
    }
    strcpy(pRoot->str, "");
}

void Insert(TreeNode *&pRoot, string pword, string pstr)
{
    TreeNode *p = pRoot;
    int nLen = pstr.length();
    for (int i = 0; i < nLen; i++)
    {
        int index = pstr[i] - 'a';
        if (p->next[index] == NULL)
        {
            TreeNode *pNode = (TreeNode *)malloc(sizeof(TreeNode));
            ZeroNode(pNode);
            p->next[index] = pNode;
        }
        p = p->next[index];
    }
    strcpy(p->str, pword.c_str());
}

 string Search(TreeNode *pRoot, string pstr)
{
    int nLen = pstr.length();
    for (int i = 0; i < nLen; i++)
    {
        if (!islower(pstr[i]))
        {
            return pstr;
        }
        int index = pstr[i] - 'a';
        if (pRoot->next[index] == NULL)
        {
            return pstr;
        }
        pRoot = pRoot->next[index];
    }
    if (strcmp(pRoot->str, "") != 0)
    {
        return pRoot->str;
    }
    else
    {
        return pstr;
    }
}

void Delete(TreeNode *pRoot)
{
    for(int i = 0; i < MAXWORDS; i++)
    {
        if (pRoot->next[i] != NULL)
        {
            Delete(pRoot->next[i]);
        }
    }
    free(pRoot);
}

int main()
{
    pRoot1 = (TreeNode *)malloc(sizeof(TreeNode));
    ZeroNode(pRoot1);
    char mars[3001];
    char word[11];
    scanf("%s", word);
    while(scanf("%s", word))
    {
        if (strcmp(word, "END") == 0)
        {
            break;
        }
        scanf("%s", mars);
        Insert(pRoot1, word, mars);
    }
    scanf("%s", word);
    getchar();
    while(gets(mars))
    {

        if (strcmp(mars, "END") == 0)
        {
            break;
        }
        string strWord;
        strWord.clear();
        string strTemp;
        strTemp.clear();
        int nLen = strlen(mars);
        for (int i = 0; i < nLen; i++)
        {
            if (islower(mars[i]))
            {
                strTemp += mars[i];
            }
            else
            {
                strTemp = Search(pRoot1, strTemp);
                strWord += strTemp;
                strWord += mars[i];
                strTemp.clear();
            }
        }
        cout<<strWord<<endl;
    }
    Delete(pRoot1);
    return 0;
}
原文地址:https://www.cnblogs.com/lzmfywz/p/3104759.html