ACM-The Coco-Cola Store

题目:

Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop, you'll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many full bottles of coco-cola can you drink?

输入

There will be at most 10 test cases, each containing a single line with an integer n (1<=n<=100). The input terminates with n = 0, which should not be processed

输出

For each test case, print the number of full bottles of coco-cola that you can drink.

样例输入

3
10
81
0

样例输出

1
5
40

题意:3个空瓶子换一瓶可乐,注意2个空瓶子的时候,借一个空瓶子的情况。

AC code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
  int n;
  while(scanf("%d", &n),n){
      int sum = 0;
      while(n>=2){
          if(n ==2){
            n++;
          }else{
            sum += n/3;
            n = n/3+n%3;
          }
      }
      cout<<sum<<endl;
   }
 return 0;
}
原文地址:https://www.cnblogs.com/lzeffort/p/6380321.html