POJ 1861 Network (Kruskal求MST模板题)


Network
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 14103   Accepted: 5528   Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion

题目链接:poj.org/problem?

id=1861

题目大意:n个点,m条线,每条线有个权值,如今要求最长的路最短且让各个点都连通,求最短的最长路,边个数和相应边

题目分析:例子有问题,应该是
1
4
1 2
1 3
3 4
裸的Kruskal注意这里要求最长路最短,而Kruskal正好是对权值从小到大排序后的贪心算法

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 15005;
int fa[MAX];
int n, m, ma, num;
int re1[MAX], re2[MAX]; 

struct Edge
{
    int u, v, w;
}e[MAX];

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

void UF_set()
{
    for(int i = 0; i < MAX; i++)
        fa[i] = i;
}

int Find(int x)
{
    return x == fa[x] ?

x : fa[x] = Find(fa[x]); } void Union(int a, int b) { int r1 = Find(a); int r2 = Find(b); if(r1 != r2) fa[r2] = r1; } void Kruskal() { UF_set(); for(int i = 0; i < m; i++) { int u = e[i].u; int v = e[i].v; if(Find(u) != Find(v)) { re1[num] = u; re2[num] = v; Union(u, v); ma = max(ma, e[i].w); num ++; } if(num >= n - 1) break; } } int main() { ma = 0; num = 0; scanf("%d %d", &n, &m); for(int i = 0; i < m; i++) scanf("%d %d %d", &e[i].u, &e[i].v, &e[i].w); sort(e, e + m, cmp); Kruskal(); printf("%d %d ", ma, num); for(int i = 0; i < num; i++) printf("%d %d ", re1[i], re2[i]); }



原文地址:https://www.cnblogs.com/lytwajue/p/7113197.html