Zoj2421 广搜

<span style="color:#330099;">/*
M - 广搜 加强
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit
 
Status
 
Practice
 
ZOJ 2412
Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1
Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE
then the water pipes are distributed like

Figure 2
Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output
For each test case, output in one line the least number of wellsprings needed.

Sample Input
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output
2
3

By Grant Yuan
2014.7.14
Zoj 2421
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;

int aa[11][4]={{1,0,0,1},{1,1,0,0}, {0,0,1,1},{0,1,1,0},{1,0,1,0},
            {0,1,0,1},{1,1,0,1},{1,0,1,1},{0,1,1,1},{1,1,1,0},{1,1,1,1}};
int m,n;
char input[51][51];
bool mark[51][51];
int top,base;
int sum;
typedef struct{
 int x;
 int y;
}node;
node q[10000];
int next[4][2]={-1,0,0,1,1,0,0,-1};

bool can(int x1,int y1,int x2,int y2,int k)
{ 
    if(x1>=0&&x1<m&&y1>=0&&y1<n&&mark[x1][y1]==0)
     {
        
         if(aa[input[x2][y2]-65][k]==1)
           {
               if(k==0){
                if(aa[input[x1][y1]-65][2]==1)
                  return 1;}
              else if(k==1){
                 if(aa[input[x1][y1]-65][3]==1)
                  return 1;}
             else   if(k==2){
                 if(aa[input[x1][y1]-65][0]==1)
                  return 1;}
             else   if(k==3){
                 if(aa[input[x1][y1]-65][1]==1)
                  return 1;}
           }
     }
     return 0;
}

void slove()
{
    int a1,b1;
    int x1,y1;
    while(top>=base){
         a1=q[base].x;
         b1=q[base].y;
        for(int i=0;i<4;i++)
          {
              x1=a1+next[i][0];
              y1=b1+next[i][1];
              if(can(x1,y1,a1,b1,i)){
                mark[x1][y1]=1;
                q[++top].x=x1;
                q[top].y=y1;
                  }}
            base++;

      }
}

int main(){
 
  while(1){
    cin>>m>>n;
    if(m==-1&&n==-1)
      break;
    sum=0;
    memset(mark,0,sizeof(mark));
    for(int i=0;i<m;i++)
      scanf("%s",&input[i]);
    
    for(int i=0;i<m;i++)
       for(int j=0;j<n;j++)
        {
            if(mark[i][j]==0){
                sum++;
              top=-1;
              base=0;
              q[++top].x=i;
              q[top].y=j;
              mark[i][j]=1;
              slove();}
        }
        cout<<sum<<endl;

    }
    return 0;
  }
</span>

原文地址:https://www.cnblogs.com/lytwajue/p/6831708.html