HDoj-1250-Hat's Fibonacci-大数

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7857    Accepted Submission(s): 2553


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
100
 

Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;  //No generated Fibonacci number in excess of 2005 digits 
int  a[10000][260];  //260*8=2080  > 2005   不能过大   ,easy超内存 
int main()          
{
    int i,j,n;
    memset(a,0,sizeof(a));
    a[1][0]=a[2][0]=a[3][0]=a[4][0]=1;
    for(i=5;i<10000;i++)
    {
      for(j=0;j<260;j++)
          a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
      for(j=0;j<260;j++){   
          if(a[i][j]>=100000000)
          {
               int temp=a[i][j]/100000000;
               a[i][j]=a[i][j]%100000000;
               a[i][j+1]+=temp;
          }
      }
    }
    while(cin>>n){
        for(i=259;i>0;i--)
           if(a[n][i]!=0)
              break;
        cout<<a[n][i];      //最后一个数不一定是刚好8位,要单独输出。否则数的前面会出现 0000
        for(j=i-1;j>=0;j--)
           printf("%08d",a[n][j]); //printf("%8d",a[n][j]);  输出时会出现 空格  %08d则将空格补0 
        cout<<endl;
    }
    return 0;
}


 
原文地址:https://www.cnblogs.com/lxjshuju/p/6917341.html