数学--数论--HDU

In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1 itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.

Input

The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).

Output

For each test case, print a single line containing an integer, denoting the answer.

Sample Input

2
1
2

Sample Output

5
7

在这里插入图片描述

打表看了一下5之后,除了6之外都不是素数。

#include<bits/stdc++.h>
using namespace std;
 
int main()
{
    int t;
    long long k;
    cin>>t;
    while(t--)
    {
        cin>>k;
        if(k==1) cout<<5<<endl;
        else cout<<k+5<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lunatic-talent/p/12798460.html