hdoj 1251 统计难题

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 20301    Accepted Submission(s): 8855


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 
Sample Input
banana
band
bee
absolute
acm
 
ba
b
band
abc
 
Sample Output
2
3
1
0
照样是一道水题,写随笔还是为了方便自己以后看,直接贴ac代码,对了,提交必须要用c++,不然会内存超限。直接贴ac代码
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
struct tree
{
    tree *child[26];
    int n;
};
void insert(char danci[],tree *root)
{

    tree *ans=root;
    int l=strlen(danci);
    for(int i=0;i<l;i++)
    {
        if(ans->child[danci[i]-'a']==NULL)
        {
            tree *temp;
            temp=(tree*)malloc(sizeof(tree));
            temp->n=1;
            for(int j=0;j<26;j++)
                temp->child[j]=NULL;
            ans->child[danci[i]-'a']=temp;
            ans=temp;
        }
        else
        {
            ans=ans->child[danci[i]-'a'];
            ans->n++;
        }
    }
}
void search(char danci[],tree *root)
{
    tree *ans=root;
    int l=strlen(danci);
    int i=0;
    for(;i<l;i++)
    {
        if(ans->child[danci[i]-'a']!=NULL)
        {
            ans=ans->child[danci[i]-'a'];
        }
        else break;
    }
    if(i==l) cout<<ans->n<<endl;
    else cout<<0<<endl;
}
int main()
{
    tree *root=(tree *)malloc(sizeof(tree));
    root->n=0;
    for(int i=0;i<26;i++)
        root->child[i]=NULL;
    char danci[12];
    gets(danci);
    while(danci[0]!='')
    {
        insert(danci,root);
        gets(danci);
    }
    while(cin>>danci)
    {
        search(danci,root);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lthb/p/4353261.html