[USACO07DEC]Sightseeing Cows(负环,0/1分数规划)

[USACO07DEC]Sightseeing Cows

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L_1_i to L_2_i (in the direction L_1_i -> L_2_i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

  • Line 1: Two space-separated integers: L and P
  • Lines 2..L+1: Line i+1 contains a single one integer: Fi
  • Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L_1_i , L_2_i , and Ti

Output

  • Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00

题意概述:
给定一张有向图,每个点求出一个权值(fun[i]),每条边有一个权值(time[i])。求图中的一个环,使得“环上各点的权值和”/“环上各边的权值和”最大。输出这个最大值。

显然的0/1分数规划
每次二分出最大值,重新建边。由一般的0/1分数规划思路,我们需要确定环上是否有一个环是正环,但是这样不容易判断。所以我们把环的权值取反,这样就可以通过判断负环来(check)了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int read()
{
	int x=0,w=1;char ch=getchar();
	while(ch>'9'||ch<'0') {if(ch=='-')w=-1;ch=getchar();}
	while(ch>='0'&&ch<='9') x=(x<<3)+(x<<1)+ch-'0',ch=getchar();
	return x*w;
}
int n,m,cnt,flag;
double inf=2000000000;
int head[1010],x[50010],y[50010],vis[1010];
double a[1010],z[50010],dis[1010];
struct node{
	int to,next;double v;
}edge[10010];
void add(int x,int y,double z)
{
	cnt++;edge[cnt].to=y;edge[cnt].v=z;edge[cnt].next=head[x];head[x]=cnt;
}
void spfa(int k)
{
	vis[k]=1;
	for(int i=head[k];i;i=edge[i].next)
	{
		int v=edge[i].to;
		if(dis[v]>dis[k]+edge[i].v)
		{
			if(vis[v]) {flag=1;return;}
			dis[v]=dis[k]+edge[i].v;
			spfa(v);if(flag) return;
		}
	}
	vis[k]=0;
}
bool check(double k)
{
	cnt=0;flag=0;for(int i=1;i<=n;i++)head[i]=vis[i]=0,dis[i]=inf;
	for(int i=1;i<=m;i++) add(x[i],y[i],k*z[i]-a[x[i]]);
	for(int i=1;i<=n;i++){spfa(i);if(flag)return true;}
	return false;
}
int main()
{
	n=read();m=read();double l=0,r=0,mid;
	for(int i=1;i<=n;i++) scanf("%lf",&a[i]),r+=a[i];
	for(int i=1;i<=m;i++) x[i]=read(),y[i]=read(),scanf("%lf",&z[i]);
	while(r-l>1e-4)
	{
		mid=(l+r)/2;
		if(check(mid)) l=mid;
		else r=mid;
	}
	printf("%.2lf",r);
}
原文地址:https://www.cnblogs.com/lsgjcya/p/9358013.html