POJ2376 Cleaning Shifts

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always

wantsto have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first

being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for

cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and

(ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10

1 7

3 6

6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts

6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

Analysis

好久没有独立写代码切题了我好菜啊

其实这题比较水,和那啥会议室选活动差不多

只要输入每头牛开始工作的时间和结束时间

按开始时间排序,while循环找到 [1,上一头牛工作结束时间+1] 的区间中结束时间最长的那个,统计答案即可

代码

貌似是史上最短代码。。。

#include<bits/stdc++.h>
#define ll long long
using namespace std;
ll n,t,ans,end=0;
struct node {
	ll s,e;
}a[25005];
bool cmp(node aa,node bb){return aa.s<bb.s;}
int main(){
	cin>>n>>t;
	for(ll i=1;i<=n;i++)cin>>a[i].s>>a[i].e;
	sort(a+1,a+n+1,cmp);
	for(ll i=1;i<=n;i++){
		ll maxend=end;
		while(a[i].s<=end+1&&i<=n){
			maxend=maxend>a[i].e?maxend:a[i].e;
			++i;
		}//找到 [1,上一头牛工作结束时间+1] 的区间中结束时间最长的那个
		--i;
		if(maxend>end){
			++ans;
			end=maxend;
		}
		if(a[i+1].s>end+1&&i<=n){printf("-1");return 0;}//如果下一头奶牛的开始时间接不上前面奶牛所能坚持的最长时间就无法实现
	}
	if(end<t){printf("-1");return 0;}//最后一头奶牛不能坚持到胜利
	printf("%d",ans);
}
原文地址:https://www.cnblogs.com/lqhsr/p/10864720.html