二叉树遍历 ,根据先序遍历序列建树

题目描述:

编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

输入:

输入包括1行字符串,长度不超过100。

输出:

可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。

样例输入:
abc##de#g##f###
样例输出:
c b e g d f a 

此题的关键就是在于建树。设置一个全局变量cnt递增,递归建树。



#include <stdio.h>
#include <stdlib.h>

char cache[101];

typedef struct Node
{
char data;
struct Node * lchild,* rchild;
};
struct Node * root;
int cnt;

struct Node * Build_tree()
{
struct Node * root;
if(cache[cnt++] == '#') root = NULL;
else
{
root = (struct Node *)malloc(sizeof(struct Node));
root -> data = cache[cnt - 1];
root -> lchild = Build_tree();
root -> rchild = Build_tree();
}
return root;
}
void in_order(struct Node *root)
{
if(root != NULL)
{
in_order(root -> lchild);
printf("%c ",root -> data);
in_order(root -> rchild);
}
}
void clean(struct Node *root)
{
if(root != NULL)
{
clean(root -> lchild);
clean(root -> rchild);
free(root);
}
}
int main()
{
int i;
while(scanf("%s",cache) != EOF)
{
cnt = 0;
root = Build_tree();
in_order(root);
clean(root);
printf("\n");
}
return 0;
}

转自: www.acmerblog.com
www.acmerblog.com 

原文地址:https://www.cnblogs.com/love533/p/2431279.html