hdu 5050

Divided Land

Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 
Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 21000)
 
Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 
Sample Input
3
10 100
100 110
10010 1100
 
Sample Output
Case #1: 10
Case #2: 10
Case #3: 110
 
Source
 
Recommend
hujie   |   We have carefully selected several similar problems for you:  5717 5716 5715 5714 5713 
 
题意是给出一对二进制数,求转化为十进制后的最大公约数,再转化为二进制输出
java随便搞一下就好了。
import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);
        int t;
        t = cin.nextInt();
        for(int cas = 1; cas <= t; cas++) {
            String p = cin.next();
            String q = cin.next();
            BigInteger a = new BigInteger(p, 2);
            BigInteger b = new BigInteger(q, 2);
            a = a.gcd(b);
            System.out.printf("Case #%d: ", cas);
            System.out.println(a.toString(2));
        }
    }
}
原文地址:https://www.cnblogs.com/lonewanderer/p/5678575.html