hdu-1856-More is better

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24825    Accepted Submission(s): 8911


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 
Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 
Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
题目大意:就是找最大的集合,输出包含个数。
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1856
 
代码:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAX=10000005;
int f[MAX],v[MAX];
int find(int n)
{
    if(n!=f[n])
    f[n]=find(f[n]);
    return f[n];
}

int main()
{  int n;
while(cin>>n)
{
    for(int i=0;i<MAX;i++)
    {f[i]=i;v[i]=1;}
    int a,b;
    int t=1;
    for(int i=0;i<n;i++)
    {scanf("%d%d",&a,&b);
     a=find(a);
     b=find(b);
     if(a!=b)
    {f[a]=b;v[b]+=v[a];t=max(t,v[b]);}
    }
   cout<<t<<endl;
}
return 0;
}
 
 
原文地址:https://www.cnblogs.com/llsq/p/5880973.html