poj 2253(kruskal)

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34968   Accepted: 11235

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:一只青蛙要从1走到2,求所有1-2的路径中最长的子段中最短的那条(minimax)。。有点难懂啊,,打个比方。
1 2 2
1 3 1.5
2 3 1
那么我们有 1 2 可以选择 ,路径长度为 2
还有 1 3 2 可以选择 路径长度 为 1.5+1 = 2.5
所以我们选择 1 3 2 答案为 1.5
这里可以用贪心的思想,利用kruskal进行添边,如果1 2 联通了就必定是这一条。。开始想复杂了,用二分+网络流去解。。结果果断TLE
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iostream>
using namespace std;
const int N = 205;
struct Point{
    double x,y;
}p[N];
struct Edge{
    int s,t;
    double v;
}edge[N*N];
int father[N];
int n;
void init(){
    for(int i=1;i<=n;i++) father[i] = i;
}
double dis(Point a,Point b){
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
int _find(int x){
    if(x==father[x]){
        return father[x];
    }
    return father[x] = _find(father[x]);
}
int cmp(Edge a,Edge b){
    return a.v<b.v;
}
double kruskal(int m){
    double MAX = -1;
    sort(edge+1,edge+1+m,cmp);
    for(int i=1;i<=m;i++){
        int a = _find(edge[i].s);
        int b = _find(edge[i].t);
        if(a!=b) {
            father[a] = b;
        }
        if(_find(1)==_find(2)){
            MAX = edge[i].v;
            return MAX;
        }
    }
}
int main()
{
    int t = 1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%lf%lf",&p[i].x,&p[i].y);
        }
        int m=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                double d = dis(p[i],p[j]);
                edge[m].s = i;
                edge[m].t = j;
                edge[m++].v = d;
            }
        }
        m--;
        double res = kruskal(m);
        printf("Scenario #%d
Frog Distance = %.3lf

",t++,sqrt(res));
    }
    return 0;
}
原文地址:https://www.cnblogs.com/liyinggang/p/5576740.html