1048 Find Coins

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 1 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1​​ and V2​​ (separated by a space) such that V1​​+V2​​=M and V1​​V2​​. If such a solution is not unique, output the one with the smallest V1​​. If there is no solution, output No Solutioninstead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

/*
    Name:
    Copyright:
    Author:  流照君
    Date: 2019/8/14 15:51:19
    Description:
*/
#include <iostream>
#include<string>
#include <algorithm>
#include <vector>
#define inf 100100
using namespace std;
typedef long long ll;
int main(int argc, char** argv)
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    ll n,m,a[inf],b[inf],temp=-1;
    fill(b,b+inf,0);
    cin>>n>>m;
    for(int i=0;i<n;i++)
    cin>>a[i];
    sort(a,a+n);
    for(int i=0;i<n;i++)
    {
        if(b[a[i]]==1&&a[i]>temp)
        {
            temp=a[i];
        }
        if(m-a[i]>0)
        {
            b[m-a[i]]=1;
        }
    }
    if(temp==-1)
    {
        cout<<"No Solution"<<endl;
    }
    else
    {
        cout<<m-temp<<" "<<temp<<endl;
    }
    return 0;
}

觉得自己还是蛮聪明的 ,

原文地址:https://www.cnblogs.com/liuzhaojun/p/11352664.html