1051 Pop Sequence 入栈 出栈模拟

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

#include<iostream>
#include<cstring>
#include<algorithm>
#include<stack>
using namespace std;
const int inf=1005;
int main()
{
int n,m,t,a[inf];
stack<int> s;
cin>>n>>m>>t;
while(t--)
{
for(int i=0;i<m;i++)
cin>>a[i];
int i=1,j=0;
while(j<m&&i<=m)
{
s.push(i);
if(s.size()>n)
break;
//cout<<s.size()<<endl;
while(s.top()==a[j]&&!s.empty()&&j<m&&i<=m)
{
//cout<<s.top()<<"%%% "<<endl;
j++;
s.pop();
//cout<<s.size()<<endl;
if(s.empty())
{
//cout<<s.top()<<endl; 当栈为空时不能使用s.top(),程序会中断,坑了我半个下午mmp
break;
}
//cout<<s.top()<<"%%% "<<endl;
}
i++;
}
if(!s.empty())
cout<<"NO"<<endl;
else
cout<<"YES"<<endl;
while(!s.empty())
s.pop();
}
return 0;
}

被搞自闭了

如果你够坚强够勇敢,你就能驾驭他们
原文地址:https://www.cnblogs.com/liuzhaojun/p/11195716.html