1038 Recover the Smallest Number string还能这样用 cmp真滴强大

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm> 
#define ll long long
#define inf  10000
using namespace std;
int cmp(string a,string b)
{
    return a+b<b+a;
}
int main()
{
    int n,m;
    string s[inf];
    cin>>n;
    for(int i=0;i<n;i++)
    cin>>s[i];
    sort(s,s+n,cmp);
    string s1;
    for(int i=0;i<n;i++)
    {
        s1+=s[i];
    }
    //cout<<s1<<" "<<s1[0]<<*s1.begin()<<endl;
    while(s1[0]=='0'&&s1.length()!=0)
    {
        s1.erase(s1.begin());
    }
    if(s1.length()==0)
    cout<<0;
    cout<<s1;
    cout<<endl;
    return 0;
}
如果你够坚强够勇敢,你就能驾驭他们
原文地址:https://www.cnblogs.com/liuzhaojun/p/11166105.html