专题四--1004

1004

题目

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5

题目大意

和第三题的思路基本完全一样,不同的是这次需要求的是所建道路的总长度,而且没有事先建好的道路。因此需要记录一下每条要建道路的长度。

AC代码

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAX=103;
int c[MAX];
struct xy
{
    int x;
    int y;
    int l;
}dis[MAX*(MAX-1)/2];;
bool cmp(xy a,xy b)
{
    return a.l<b.l;
}
int find(int x)
{
    while(c[x]!=x){
        x=c[x];
    }
    return x;
}
void merg(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y){
        if(x>y)
            c[x]=y;
        else c[y]=x;
    }
}
int main()
{
    //freopen("date.in","r",stdin);
    //freopen("date.out","w",stdout);
    int n,res;
    while(cin>>n&&n!=0){
        res=0;
        for(int i=1;i<=n;i++){
            c[i]=i;
        }
        for(int i=0;i<n*(n-1)/2;i++){
            cin>>dis[i].x>>dis[i].y>>dis[i].l;
            /*if(dis[i].x>dis[i].y)
                swap(dis[i].x,dis[i].y);*/
        }
        sort(dis,dis+n*(n-1)/2,cmp);
        for(int i=0;i<n*(n-1)/2;i++){
            if(find(dis[i].x)!=find(dis[i].y)){
                res+=dis[i].l;
                merg(c[dis[i].x],c[dis[i].y]);
            }
        }
        cout<<res<<endl;
    }
}
原文地址:https://www.cnblogs.com/liuzhanshan/p/5648587.html