栈之火车进站和出站

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 
Sample Input
3 123 321
3 123 312
 
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH
 
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
题目大概意思:有N辆火车,以序列1方式进站,判断是否能以序列2方式出栈。进站不一定是一次性进入,也就是说中途可以出站。
 

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <stack>
using namespace std;
int main(void)
{
stack<char>s1;
stack<char>s2;
int n,i,j,t,a[1000];
char c[100010],d[100010];
while(scanf("%d",&n)!=EOF)
{j=0;
scanf("%s",c);
scanf("%s",d);
for(i=n-1;i>=0;i--)
s1.push(d[i]);
for(i=0;i<n;i++)
{
s2.push(c[i]);
a[j++]=1;
while(!s2.empty()&&s1.top()==s2.top())
{
s1.pop();
s2.pop();
a[j++]=0;
}
}
if(s1.empty()&&s2.empty())
{
printf("Yes. ");
for(i=0;i<2*n;i++)
{
if(a[i]==1) printf("in ");
else printf("out ");
}
}
else printf("No. ");
printf("FINISH ");
}
return 0;
}                答案错误

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <stack>
using namespace std;
int main(void)
{
stack<char>s1;
stack<char>s2;
int n,i,j,t,a[1000];
char c[100010],d[100010];
while(scanf("%d",&n)!=EOF)
{j=0;
scanf("%s",c);
scanf("%s",d);
for(i=n-1;i>=0;i--)
s1.push(d[i]);
for(i=0;i<n;i++)
{
s2.push(c[i]);
a[j++]=1;
while(!s2.empty()&&s1.top()==s2.top())
{
s1.pop();
s2.pop();
a[j++]=0;
}
}
if(s1.empty()&&s2.empty())
{
printf("Yes. ");
for(i=0;i<2*n;i++)
{
if(a[i]==1) printf("in ");
else printf("out ");
}
}
else

{

printf("No. ");

while(!s1.empty())
s1.pop();                      如果不能实现 ,那也就是说两个栈没有清空 ,必须清空才能继续下一个实例;             

while(!s2.empty())
s2.pop();

}

printf("FINISH ");

}
return 0;
}

原文地址:https://www.cnblogs.com/liuming1115/p/4439354.html