【poj3070】Fibonacci

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

HINT

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

 
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
void mul(int a[2][2],int b[2][2]){
    int c[2][2];
    memset(c,0,sizeof(c));
    for (int i=0;i<2;i++)
        for (int j=0;j<2;j++)
            for (int k=0;k<2;k++){
                c[i][j]=(c[i][j]+a[i][k]*b[k][j])%10000;
            }
    memcpy(a,c,sizeof(c));
}
int main(){
    int n;
    while (cin>>n && n!=-1){
        int a[2][2]={{0,1},{1,1}};
        int f[2][2]={{0,1},{0,0}}; //为了好算,写成2*2的 
        while (n>0){
            if (n&1) mul(f,a);
            mul(a,a);
            n>>=1;
        }
        cout<<f[0][0]<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/liumengyue/p/5172034.html