1094 The Largest Generation (25分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]
 

where ID is a two-digit number representing a family member, K (>) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
 

Sample Output:

9 4

这道题考察给定一棵树,求最大人口

#include "iostream"
#include "vector"
#include "map"
using namespace std;
int N, M, parent, tmp_num;
struct node {
    int level = -1;
    vector<int> child;
}n[999999];
void dfs(int root, int level) {
    n[root].level = level;
    for(int i = 0; i < n[root].child.size(); i++) 
        dfs(n[root].child[i], level + 1);
}
map<int, int> m;
int main() {
    scanf("%d%d", &N, &M);
    while(M--) {
        scanf("%d%d", &parent, &tmp_num);
        n[parent].child.resize(tmp_num);
        for(int i = 0; i < tmp_num; i++) 
            scanf("%d", &n[parent].child[i]);
    }
    dfs(1, 1);
    for(int i = 1; i <= N; i++)
        if(n[i].level != -1) m[n[i].level]++;
    int mk = -1, mv = -1;
    for(auto it = m.begin(); it != m.end(); it++)
        if(it->second > mv) {
            mv = it->second;
            mk = it->first;
        }
    printf("%d %d", mv, mk);
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12910205.html