1126 Eulerian Path (25分)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
 

Sample Output 1:

2 4 4 4 4 4 2
Eulerian
 

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
 

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian
 

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
 

Sample Output 3:

3 3 4 3 3
Non-Eulerian

考察图连通分量和顶点的度。如果图连通分量为1,并且顶点的度为都偶数,则打印各顶点的度 + Eulerian。如果刚好有2个顶点的度是奇数,则为Semi-Eulerian,其余都是Non-Eulerian。

我们首先进行dfs进行查看图有多少联通分量,之后再进行判断顶点度的个数即可。

#include <iostream>
#include <vector>
using namespace std;
int degree[99999] = {0}, vis[99999] = {0}, N, M, a, b, odd = 0, conn = true, part = 0;
vector<int> G[99999];
void dfs(int n) {
    if(vis[n]) return;
    vis[n] = 1;
    for(int i = 0; i < G[n].size(); i++)
        dfs(G[n][i]);
}
int main() {
    scanf("%d%d", &N, &M);
    while(M--) {
        scanf("%d%d", &a, &b);
        degree[a]++; degree[b]++;
        G[a].push_back(b);
        G[b].push_back(a);
    }
    // 判断连通分量
    for(int i = 1; i <= N; i++) {
        if(!vis[i]) {
            dfs(i);
            part++;
        }
    }
    if(part > 1) conn = false; // 如果连通分量大于1,则设置false
    for(int i = 1; i <= N; i++) 
        if(degree[i] % 2 != 0) odd++;
    printf("%d", degree[1]);
    for(int i = 2; i <= N; i++) 
        printf(" %d", degree[i]);
    if(odd == 0 && conn) printf("
Eulerian
");
    else if(odd == 2 && conn) printf("
Semi-Eulerian
");
    else printf("
Non-Eulerian
");
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12837084.html