PAT Advanced 1120 Friend Numbers (20分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 1.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12
 

Sample Output:

4
3 6 9 26

这题考察朋友数,也就是各位相加就是朋友数,我们使用一个judge数组进行映射即可。

#include <iostream>
#include <vector>
using namespace std;
bool judge[10000] = {0};
int main() {
    int N, tmp, sum;
    scanf("%d", &N);
    for(int i = 0; i < N; i++){
        sum = 0;
        scanf("%d", &tmp);
        while(tmp != 0) {
            sum += (tmp%10);
            tmp /= 10;
        }
        judge[sum] = 1;
    }
    vector<int> ans;
    for(int i = 0; i < 10000; i++)
        if(judge[i]) ans.push_back(i);
    for(int i = 0; i < ans.size(); i++)
        if(i == 0) printf("%d
%d", ans.size(), ans[i]);
        else printf(" %d", ans[i]);
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12249018.html