PAT Advanced 1081 Rational Sum (20分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3
 

Sample Output 1:

3 1/3
 

Sample Input 2:

2
4/3 2/3
 

Sample Output 2:

2
 

Sample Input 3:

3
1/3 -1/6 1/8
 

Sample Output 3:

7/24

在格式化的时候,要注意进行规整代码,乙级得考虑0这种特殊情况,防止浮点错误

#include <iostream>
#include <vector>
using namespace std;
struct frac{
    long long up, down, sign = 1;
};
long long gcd(long long a, long long b) {
    return b == 0 ? a: gcd(b, a%b);
}
int main() {
    long long N, multi = 1, sum = 0;
    scanf("%lld", &N);
    vector<frac> v;
    for(int i = 0; i < N; i++) {
        frac tmp;
        scanf("%lld/%lld", &tmp.up, &tmp.down);
        if(tmp.up < 0) {
            tmp.sign = -1;
            tmp.up = -tmp.up;
        }
        v.push_back(tmp);
        multi = multi * tmp.down;
    }
    for(int i = 0; i < N; i++)
        sum += (multi / v[i].down * v[i].up * v[i].sign);
    if(sum < 0) printf("-");
    if(sum == 0) {
        printf("0");
        return 0;
    }
    sum = abs(sum);
    int integer = sum / multi, blank = 0;
    sum %= multi;
    if(integer > 0) {
        printf("%d", integer);
        blank = true;
    }
    long long m = gcd(multi, sum);
    if(sum != 0) {
        if(blank) printf(" ");
        printf("%lld", sum/m);
        if(multi/m != 1L) printf("/%lld", multi/m);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12247387.html