PAT Advanced 1027 Colors in Mars (20分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71
 

Sample Output:

#123456

这道题考察了进制转换,因为只有两位数,所以我们的方式处理比较简单

#include <iostream>
using namespace std;
int main() {
    int a, b, c;
    char ch[] = "0123456789ABC";
    scanf("%d%d%d", &a, &b, &c);
    printf("#%c%c%c%c%c%c", 
        ch[a/13], ch[a%13], ch[b/13], 
        ch[b%13], ch[c/13], ch[c%13]);
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12238952.html