PAT Advanced 1147 Heaps (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
 

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目大意:这题是一道堆题,给定一个数组,判定是否为堆。

我的想法,从(N/2)开始往前循环,第N/2是倒数第一个父亲。往前,判定左子树是否符合,如果存在右子树,判定右子树是否符合。

最后修正打印。

注意:判定最后一个父亲是N/2不是vector.size()/2。这边有一个测试点

后面那个很简单,一个后序遍历进行打印即可

#include <iostream>
#include <vector>
using namespace std;
vector<int> v;
void postTraserve(vector<int>& res,int index){
    if(index*2<v.size())postTraserve(res,index*2);
    if(index*2+1<v.size())postTraserve(res,index*2+1);
    res.push_back(v[index]);
}
int main(){
    int M,N;
    int heapType;/** 1 maxHeap -1 minHeap 0 notHeap */
    cin>>M>>N;
    v.resize(N+1);
    while(M--){
        /** input */
        for(int i=1;i<=N;i++)
            cin>>v[i];
        /** judge */
        v[1]>v[2] ? heapType=1:heapType=-1;
        for(int i=N/2;i>0;i--){
            if(v[i]<v[i*2]&&heapType==1) heapType=0;
            if(v[i]>v[i*2]&&heapType==-1) heapType=0;
            /**如果右孩子存在,判定右孩子 */
            if(i*2+1<=N){
                if(v[i]<v[i*2+1]&&heapType==1) heapType=0;
                if(v[i]>v[i*2+1]&&heapType==-1) heapType=0;
            }
        }
        if(heapType==1) cout<<"Max Heap"<<endl;
        else if(heapType==0) cout<<"Not Heap"<<endl;
        else cout<<"Min Heap"<<endl;
        vector<int> res;
        postTraserve(res,1);
        for(int i=0;i<res.size();i++)
            if(i!=res.size()-1) cout<<res[i]<<" ";
            else cout<<res[i];
        cout<<endl;
    }
    system("pause");
    return 0;
}
原文地址:https://www.cnblogs.com/littlepage/p/12207298.html