A1042 Shuffling Machine (20)

1042 Shuffling Machine (20)(20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

思考

这个初试顺序是1-13,S、H、C、D、J,其中J只有两张

就是指定顺序的算法,这个顺序用指针最好了、

先要存进去,

开一个数组??存的东西可能为3个字符,来了,经典问题,因为 c语言的字符串不好用,一个字符串就是一个字符数组,应该怎么办来着?其实熟练应用数据结构的做法,就知道该怎么办了,然而还是没有这种肌肉记忆。

太秀了,真的太秀了。

const——error: variably modified ‘buf’ at file scope

2014年11月13日 13:55:43

阅读数:3792

const变量在C和C++之中还是有不少区别的。在C中,const修饰的变量一般只当成“只读的”,而不是将其作为一个常量。因此如果像下面这样声明

const int SIZE;   // legal in C

不过在C++中,const修饰的变量都是常量,这和直接使用0,1,2...以及字符串”open file error!“一样,所以在声明的时候都需要赋值。

如果只是这样声明

const int SIZE;     //illegal in C++
const int SIZE = 100;    //legal in C++

由于const修饰的变量在C中不能直接当成常量,所以如果在全局声明数组,不能使用const变量做下标。比如

const int SIZE = 100;



char buf[SIZE];        // illegal in C, but legal in C++

如果在C语言这样用就会报错——error: variably modified ‘buf’ at file scope。但是如果在C++中由于SIZE会当成常量存储在堆栈特殊的位置,所以可以正确使用。

AC代码

#include <stdio.h>
//const int N = 54;
#define N 54//这里由于c语言和c++对const定义的不同造成的,在c中为只读变量,而非常量
char mp[5] = {'S', 'H', 'C', 'D', 'J'};//为输出做准备
int start[N], end[N], next[N];

int main() {
    int K;
    scanf("%d", &K);
    for(int i = 1; i <= N; i++) {
        start[i] = i;//初始化牌的编号
    }
    for(int i = 1; i <= N; i++) {
        scanf("%d", &next[i]);//牌的新位置
    }
    for(int step = 0; step < K; step++) {
        for(int i = 1; i <= N; i++) {
            end[next[i]] = start[i];//把牌放到新位置
        }
        for(int i = 1; i <= N; i++) {
            start[i] = end[i];//复制一份,为下一次改变牌序做准备
        }
    }
    for(int i = 1; i <= N; i++) {
        if(i != 1) printf(" ");
        start[i]--;//这一句是为了啥?,给定牌号比如53,那么就是指J1,J对应4,1就是除以13的余数
        //因为13/13为1,所以偏了一位,而余数为0的那些输出是13,所以是取模为12,再加1调节。
        //储存办法,简单粗暴,我还想开字符数组,真的是愚蠢,天然的预先编号系统转换。
        printf("%c%d", mp[start[i] / 13] , start[i] % 13 + 1);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/lingr7/p/9363067.html