HDU-2138 How many prime numbers

Description

 Give you a lot of positive integers, just to find out how many prime numbers there are.

Input

There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

Output

For each case, print the number of prime numbers you have found out.

Sample Input

3

2 3 4

Sample Output

2


判断到sqrt(n)即可。

#include <iostream>
#include <cmath>
using namespace std;

int main(void)
{
    int t;
    long num[2000];
    
    while(cin >> t)
    {
        int s = 0;
        for(int i = 0; i < t; i++)
        {
            cin >> num[i];
            for(long j = 2; j <= sqrt(num[i]; j++)
            {
                if(num[i] % j == 0)
                {
                    s++;
                    break;
                }
            }
        }
        cout << t-s << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/limyel/p/6623386.html